Slow Performance
Incident Report for MindTouch
Resolved
This issue was identified to be caused by a temporary spike in resources for a single application server. MindTouch Engineering resolved this issue yesterday (10/4) at 7:05 a.m. PDT, and will be implementing methods to prevent performance issues from reoccurring in the future.
Posted 10 months ago. Oct 05, 2016 - 15:51 UTC
Investigating
MindTouch Engineering is investigating an issue causing some sites to load slower than normal. We expect this issue to be rectified soon, and will post more details here shortly. Thank you for your patience during this time.
Posted 10 months ago. Oct 04, 2016 - 13:58 UTC