Slowed Performance
Incident Report for MindTouch
Resolved
Amazon has issued a statement confirming their S3 services have been fully restored.

MindTouch Engineering has confirmed that both MindTouch site performance as well as file attachment and image rendering are successfully back to normal operations. We sincerely thank all of our users for their patience today, and please don't hesitate to reach out to MindTouch Support at support@mindtouch.com if you have any questions.

(and yes, we believe this means all of our Netflix schedules are back on track for tonight, too...)
Posted 10 months ago. Feb 28, 2017 - 23:16 UTC
Update
Amazon has provided an update that performance is starting to slowly restore, though they have not provided a final ETA on full resolution.

MindTouch utilizes Amazon S3 for file attachment storage purposes. With that said, MindTouch users may start to see slightly faster performance for MindTouch sites, though keep in mind that images and file attachments may still experience issues during this time.
Posted 10 months ago. Feb 28, 2017 - 22:04 UTC
Update
Due to ongoing performance issues experienced at Amazon Web Services (AWS), MindTouch sites are continuing to experience slowed response times. At this time, site performance is ranging from slowed performance to loading an Oops page in rare cases.

We're continuing to work closely with Amazon to ensure the MindTouch user experience is back to normal load times. Hopefully this will be fixed soon so we can all watch Netflix this evening.
Posted 10 months ago. Feb 28, 2017 - 19:36 UTC
Update
We have determined this morning's issues are being caused by slowed performance within Amazon Web Services' (AWS) S3 service. Along with a majority of other web services, MindTouch utilizes S3 for file storage purposes within MindTouch sites.

MindTouch Engineering is working closely with Amazon to restore normal performance. Their status page is available at the URL listed below. Rest assured we're working with them closely at this time:

https://status.aws.amazon.com

We will update this thread again shortly as updates are available.
Posted 10 months ago. Feb 28, 2017 - 18:15 UTC
Identified
MindTouch Engineering has identified an issue where some MindTouch sites are loading slower than normal. Our teams are looking into this right now and are working to restore normal performance as quickly as possible. Stay tuned to this channel for updates, and please feel free to reach out to MindTouch Support at support@mindtouch.com if you have any questions.

Thank you for your patience during this time.
Posted 10 months ago. Feb 28, 2017 - 17:58 UTC