MindTouch degraded performance: Editor
Incident Report for MindTouch
Resolved
The MindTouch Product Release went out just a few minutes ago. MindTouch Support and Engineering have tested that the Editor in MindTouch is working as expected at this time.

Please reach out to MindTouch Support if the Editor on your MindTouch site still does not open as expected and a MindTouch Support Agent will assist in diagnosing the issue.

Thank you for your continued patience.
Posted Nov 29, 2018 - 23:38 UTC
Identified
The MindTouch Engineering team has acknowledged an issue preventing the MindTouch Editor from opening. This is not affecting all sites and will be resolved with the release slated for today.

If your site is experiencing issues with the Editor loading, please reach out to MindTouch Support for an update or follow the Status Page for an update on this release.
Posted Nov 29, 2018 - 19:30 UTC
This incident affected: Application (General Service).