MindTouch degraded performance: Slow load time
Incident Report for MindTouch
Postmortem

Customer Business Impact:

From approximately February 17th, 16:40:00 UTC to 16:48:00 UTC, some MindTouch sites experienced intermittent slowness.

Problem Summary:

MindTouch sites were slower than expected, because for some time the number of resources available was lower than needed. Traffic was fluctuating up and down at a high rate, so automatic scaling up / down of resources was not effective.

Recovery:

Servers were scaled up and the minimum number of resources was increased to handle the high traffic.

Root Cause:

This incident was caused by unusual traffic spikes. It takes some time for new servers to start and be configured. During this brief time, some slowness may have been experienced.

Corrective Actions:

MindTouch Engineering is constantly working to improve the capability at which we can handle high traffic. We will continue to monitor and increase the number of minimum servers if this issue persists.

Posted Feb 17, 2020 - 23:57 UTC

Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 19:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2020 - 17:48 UTC
Investigating
MindTouch Engineering is looking into issues related to slow load on MindTouch sites.
Posted Feb 17, 2020 - 17:21 UTC
This incident affected: Application (General Service), Search, In-Product Contextual Help, Email Services, MindTouch Success Center, and Analytics.