System Email Service Interruptions
Incident Report for MindTouch
Resolved
Our email service provider has confirmed that our email services have been fully restored.

MindTouch Engineering has verified that all notification emails that were previously delayed have been successfully delivered. We sincerely thank all of our users for their patience. Please don't hesitate to reach out to MindTouch Support at support@mindtouch.com if you have any questions.
Posted 7 days ago. Jun 15, 2017 - 23:50 UTC
Update
Thank you for your continued patience. MindTouch Engineering is actively working with our email service provider to resolve the issue causing a delay in automated emails. While we do not currently have an estimated time for resolution, we will continue to update this thread with more details.
Posted 7 days ago. Jun 15, 2017 - 17:43 UTC
Identified
MindTouch Engineering has identified an issue with automated emails being delayed and is actively working on a resolution. These emails include new user creation emails, user feedback, page notifications as well as reset password emails. Thank you for your patience--we will have this resolved shortly. For additional questions please reach out to support@mindtouch.com.
Posted 8 days ago. Jun 14, 2017 - 21:42 UTC