MindTouch Service Degradation
Incident Report for MindTouch
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 21:32 UTC
Investigating
The MindTouch Engineering team is investigating reports of degraded performance.
Posted Jun 13, 2023 - 20:40 UTC
This incident affected: Application (General Service), Search, In-Product Contextual Help, Email Services, MindTouch Success Center, and Analytics.