MindTouch degraded performance: Slow load time
Incident Report for MindTouch
Postmortem

Customer Business Impact:

From approximately February 12th, 5:20:00 UTC to 5:45:00 UTC, all MindTouch sites experienced intermittent slowness and errors.

Problem Summary:

An infrastructure configuration was unintentionally changed, causing several server processes to fail under load.

Recovery:

The configuration file was reverted back to the latest working version.

Root Cause:

MindTouch Engineering is upgrading certain areas of its infrastructure to be able to handle higher loads. During the upgrade, an unintended change to the configuration was performed. This caused several server processes to fail due to insufficient resources.

Corrective Actions:

MindTouch Engineering is working to automate manual processes so that these issues can be avoided. Future updates to the infrastructure configuration will be done through an automated process.

Posted Feb 14, 2020 - 21:57 UTC

Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 06:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 13, 2020 - 06:09 UTC
Investigating
MindTouch Engineering is looking into issues related to slow load times on MindTouch sites.
Posted Feb 13, 2020 - 05:50 UTC
This incident affected: Application (General Service), Search, In-Product Contextual Help, Email Services, MindTouch Success Center, and Analytics.