MindTouch Service Degradation: Sites unavailable, slow load times and 500 errors
Incident Report for MindTouch
Resolved
The issue has been rectified and sites are functioning as normal.
Posted Jul 06, 2023 - 15:26 UTC
Investigating
MindTouch Service Degradation: Sites unavailable. The MindTouch Engineering team is investigating reports of site unavailability.
Posted Jul 06, 2023 - 15:03 UTC
This incident affected: Application (General Service), Search, In-Product Contextual Help, and MindTouch Success Center.