MindTouch Service Degradation: Intermittent Slow load times or Sites unavailable
Incident Report for MindTouch
Resolved
The issue has been identified and resolved. Sites are now loading properly.
Posted Feb 29, 2024 - 19:59 UTC
Investigating
MindTouch Service Degradation: Sites unavailable. The MindTouch Engineering team is investigating reports of site unavailability.
Posted Feb 29, 2024 - 19:45 UTC
This incident affected: Application (General Service), Search, In-Product Contextual Help, MindTouch Success Center, and Analytics.